U盘安装DragonFlyBSD 3.6.0记

说不出来的对NetBSD的失望,今天看到DFly(DragonFly BSD的缩写)发布3.6.0,实现了很多重要功能,包括Intel i915和AMD/ATI Radeon KMS驱动的移植(移植自FreeBSD的代码树),安全无锁定多线程等等。遂决定安装到鄙人的移动硬盘体验之(SSD太小了塞不下了)。

准备安装

  1. 下载最新的img镜像文件(img是写入到U盘的镜像,iso是刻录CD的)。
  2. 在*nix(Linux、BSD或Mac OS X)下用dd命令刻录到U盘(要求2G以上,不含2G),Windows平台可以用ImageWriter等类似软件。

安装DFly

设置电脑从U盘启动不用说了吧。对着官方文档安装吧。

体验为主,就不要用HAMMER文件系统了(HAMMER要求50G以上的空间-_-#),继续用UFS吧。另,安装DragonFly BSD需要MBR的主分区(Primary),不支持安装到逻辑分区(Logical)上,不知道是否支持GPT分区表格式。

可能因为有过NetBSD的安装经验吧,DragonFly BSD的安装过程感觉更加简单易上手。

安装桌面环境

可以自己编译,当然我建议是安装预编译好的二进制包。以安装KDE 4为例,tty下(废话,X都没装,当然是在tty下)输入:

pkg install xorg kde firefox gtk-qt-engine gtk-oxygen-engine wqy-fonts

一口气把X11、KDE、Firefox、GTK的Oxygen组件(让GTK+程序在KDE下显示得好看一点)、文泉驿字体都装上。官方文档说的kde4根本不存在,因为仓库里已经没有kde3了……所以kde指的就是kde4!(注意了,这会把全套kde组件都安装上,占用硬盘3G,很多无聊的组件你可能并不想安装上)

GTK的外观设置手动选oxygen-gtk吧,选和KDE一致会有点问题……

当然,bash、vim这些就是个人喜好问题了,我也装了。然后编辑.profile文件,把/usr/local/kde4/bin加入到PATH中,在export PATH前面加上一行:

PATH=$PATH:/usr/local/kde4/bin

修改.xinitrc文件,内容如下:

export XMODIFIERS="@im=fcitx"
export GTK_IM_MODULE=xim
export QT_IM_MODULE=fcitx
export LANG=zh_CN.UTF-8
export LC_CTYPE=zh_CN.UTF-8
export LC_ALL=zh_CN.UTF-8
exec startkde4

分别设置了fcitx输入法要求的系统环境变量,把语言设置为中文简体,最后一条是启动KDE4的指令。注:GTK_IM_MODULE我一开始设置成fcitx的时候在Firefox下无法输入,后来改成xim就好了。

默认Bash

和NetBSD一样,通过chsh命令。

把Shell改成/usr/local/bin/bash就可以了。反正我暂时是没有想学习一种新Shell的冲动的。所以来BSD也默认用Bash。

(本来想插一张图的,不知道为什么Firefox总说HTTP错误……)

总体感受

总有人说BSD系统稳定得一塌糊涂,各种秒Linux之类的。暂时保持谨慎一点吧,Linux的硬件支持不是BSD能比的,虽然初步支持AMD Radeon KMS驱动了,不过还仅仅是刚开始,现在OpenGL就不能用,KDE下还是蛋疼地XRender渲染。。。打算等下换个轻量级的DE了。

启动速度上,DragonFly BSD明显比NetBSD慢……真心话,不过dfly的开发速度是很快的,很快就有系统更新,而且是真的「更新」,不像NetBSD对新事物反应速度这么慢。dfly只专注于i386和amd64两个平台,支持平台倒明显是最少。

就这样吧,接下来会持续更新DragonFly BSD的文章。

Published by

librehat

自由軟體萬歲!

16 thoughts on “U盘安装DragonFlyBSD 3.6.0记”

    1. 我有一直关注DragonFly的,但是它没有改进对Radeon驱动的支持,所以还是不打算用。继续等BSD家族完善对A卡的支持。

  1. 再请教一个依赖关系的问题,bsd下面通常会有一个软件多个版本的包,但是很多时候它会依赖特定版本,而不是装一个就可以,比如jdk7u51需要gcc4.6,pgadmin3需要postgre-client-9.0,…这个比较郁闷!
    它的ports里怎么会遗留那么多开发者都已经不再技术支持的版本?比如php,从5.1到5.5,apache,pgsql也都是
    ports里的p5-xxxxx是干嘛用的?非常多,时不时的依赖一下…

  2. 他们的开发模式以前看过一些书,还是知道的!
    udev不清楚,不过,systemd和wayland这种linux only软件应该很难进入bsd系统!
    咱俩的无线网卡一个型号,archlinux需要手动下载安装模块,只遇到bt5中自带,现在一直外挂usb无线使用
    感觉bsd有点排斥gpl,等啃的差不多了就开始做ports,dfbsd跟fbsd的ports不完全一样,包不是一一对应,有差别!
    记得我上次装fbsd里面的shell是ksh,现在怎么没了?xorg需要bash依赖?

  3. 不过freebsd跟linux差别的确挺大的,或者说是非常大!

    很多linux中基础的东西在fbsd下面成为版本不是一般过时,gcc默认4.6,gcc编译的pkg用的是4.2.1,……

    驱动,这个也很有趣,nvidia的开原驱动和nv闭源驱动可以同时安装,不过我笔记本的无线驱动在fb下依然over……

    gnome,这个玩意的3.8需要systemd,弄个3.6也行啊!听说openbsd用的就是3.8,比较强悍!……

    之前网络管理用的是NetworkManager,查了下,fb下面没有这个东东!你在kde下用的什么管理网络?

    抱怨一下中文handbook.43188(英文43687,14年),11年的,N多东西过时,没办法天天啃英文!中文ports手册,09年的,不过好似还能用!刚做了个codeblocks13.12的ports,刚下午发现官方更新了,官网显示8天前更新,但貌似我前天时候ports还是旧的!郁闷……

    1. 是这样的,Linux属于那种快速开发,feature >= stability的菜市场模式,BSD系统都是大教堂的开发模式,所以stability >= feature,自然很多组件(尤其是现代软件)版本会要落后一些。
      udev和systemd在FreeBSD开发者社群里已经开始讨论了,不知道到11.0会不会加入。
      不过这不代表BSD就不能用啊,对于较为老旧的硬件支持是很好的,无线驱动的话我的笔记本电脑也不行(Broadcom BCM43貌似支持不好)。我没有在BSD里使用KDE,我一般用Fedora Linux……
      文档就应该啃英文,中文翻译有时候都看不懂,翻译的版本已经过时更是家常便饭。ports里的软件更新速度很慢的,因为一般软件说Unix平台的时侯都只考虑Linux,所以需要维护团队仔细测试才会更新。

  4. 裝fb了,這廝也用hal,而且貌似是xorg依賴,更神奇的是莫名其妙的就把dolphin給裝上了…
    用慣了linux,fb裡頭各種找不到,很多常用的命令統一被替換!基本系統之外安裝的程序路徑改為/usr/local/
    常用的兩個軟件,codeblocks, zendstudio,cb在ports,pkg都沒有,zs看來需要linux二進制兼容了!gcc統一成一個包了…
    繼續看手冊中…

  5. 請教,dfBSD裡kde的文件管理器是哪個包?最小安裝,但就是這個不知道在哪裡!

    hal,dbus,前者的確十分讓人頭疼!後者貌似還行……

    不知道在FB的kde裡應該不再需要hal了!

    1. FreeBSD里我不太清楚,但是dfly的HAL好像有bug呢,我的KDE只要开起了HAL就会卡死。你可以用pkg search kde找找看,记得有个base还是minimum之类的包。

      P.S.个人桌面系统用BSD还是用FreeBSD比较靠谱

Comments are closed.